Jump to content

Welcome to NikonForums.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Nikon FTZ Tamron 70-210 f/4 Major issues

  • Please log in to reply
No replies to this topic



    New Member

  • Forum Member
  • Pip
  • 1 posts
  • Country Flag

I bought an FTZ and a new Tamron 70-210 f/4 last September to go with my new Z5 as my telephoto lens. Unfortunately, when it arrived it didn’t work so I bought the tap-in console and updated the firmware on the 70-210 to a Z-compatible version. When I tried it at first it worked, took some test shots and everything was fine. The next day when I take it out I start seeing the same error as when I first used the lens before the firmware update, “Error, Release Shutter to Reset”. I tried updating the firmware again but the same problem occurred so I sent it to Tamron for repair and they ended up doing “FIRMWARE UPDATE REQUIRED”. When I got the lens back it started working again for the first few days, but of course, when I went on a trip with it stopped working again. Since then, it will randomly work around 10% of the time and the rest shows the same error message “Error, Release Shutter to Reset”

I recently sent my FTZ to Nikon for repair and when I got it back the technician's note says “We could not replicate the error you described and it works on Nikon equipment”

I once again updated my camera firmware, ftz firmware, and lens firmware and yet I still get the same error message.

I doubt my Z5 is the issue as it works perfectly fine with my 24-70 f/4 and I have never had issues with it. I have tried everything I can to fix it, non CPU lens data, manual focus, re-attaching the lens to the ftz and the camera, cleaning the electrical contacts and nothing works.

Any help would be much appreciated as I have a trip coming up again very soon.