Jump to content

Welcome to NikonForums.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

70-200 + UV Filter Problem help ASAP

lens help problem issue

  • Please log in to reply
3 replies to this topic

#1
lewisroberts31

lewisroberts31

    New Member

  • Forum Member
  • Pip
  • 2 posts
  • Country Flag

ive just purchased a 70-200 2.8 nikon lens and also a 77mm hoya uv filter as i thought this would fit however i cannot seem to attach it? am i doing something wrong or have i got the wrong size filter??



#2
Merco_61

Merco_61

    Nikonian

  • Premium Member
  • PipPipPipPipPipPipPipPip
  • 7,157 posts
  • Country Flag
  • LocationUppsala, Sweden

Site Supporter

It should work, if the filter really is a 77 mm. Have you checked the diameter yourself? Sometimes the order, box and filter are not the same ;).



#3
mikew

mikew

    Forum Veteran

  • Forum Member
  • PipPipPipPipPipPipPip
  • 653 posts
  • Country Flag
  • LocationNorth East Lincs

Have you tried placing the filter on the lens and gently rotating it the wrong way a little before going the right way.



#4
fallout666

fallout666

    Forum Veteran

  • Forum Member
  • PipPipPipPipPipPipPip
  • 528 posts
  • Country Flag
  • Locationcfl area of space coast

it should fit since i own first gen 70-200mm nikpon check to see if filter and lens does not have bents to it since should just screw on.







Also tagged with one or more of these keywords: lens, help, problem, issue